Lösung für MacBook Pro WLAN-Probleme

Wer glaubt, dass er nun zu den Glücklichen gehört, da er sich ein neues MacBook Pro mit Retina-Display gekauft hat, wird bald merken, dass Apple beim WLAN schlampig gearbeitet hat.

Spätestens dann nämlich, wenn er sich als mobiler Arbeiter in unterschiedliche WLANs einzuloggen hat, wird der stolze Besitzer versucht sein, dass neue Alu-Chassis einmal seiner wahren Bestimmung (Motto: Ich war eine Dose, Alu zu Alu) zu übergeben.

Harmlos ist ja noch die Mavericks-Unart, immer wieder die WLAN-Verbindung zu verlieren, vor allem beim Beenden des Ruhezustands (meist dem Aufklappen) und erst nach Minuten wieder aufzunehmen.

Wenn der Tipp, Bluetooth oder WLAN vorübergehend zu deaktivieren, nicht funktioniert und plötzlich Verbindungen beendet werden, die Performance stark schwankt und Meldungen wie „Zeitüberschreitung bei Verbindung“ spätestens dann werden auch geduldige und leidensfähige Nutzer ratlos bis wütend.

Erst durch Runterfahren und Neustart, durch diverse kleine Tricks und viele investierte Stunden kann das WLAN wieder für ein paar Stunden einigermassen funktionieren. Oft jedoch nur bis zum Zuklappen bzw. Neustarten.

Die Community-Foren sind voll von Berichten verzweifelter und frustrierter Mac-User. Leider wird dort kaum eine vernünftige Lösung präsentiert, sondern die wildesten und meist vollkommen sinnfreien Vorschläge gemacht, wovon die absurdesten und dümmsten durchaus eine Prämierung verdient hätten.

Apple lässt das alles ins Kraut schiessen, ohne einen Fix anzubieten. Die offiziellen Tipps von Apple gehen alle in die Richtung, ein Update auf das allerneueste Release löst jedes Problem. Dabei ist gerade diese Lösung hier falsch. Die Produkt- und Servicemanager des MacBook Pro ignorieren 1.470.000 Google-Ergebnisse und Hunderttausende Kunden. Tim Cook sollte sie als nächste rausschmeissen (nach Scott Forstall und John Browett.)

WLAN-Probleme beim MacBook Pro
Verdammt, schon wieder keine Internet-Verbindung

Aber nun zur Lösung:

Die 100% Lösung des MacBook Pro WLAN-Problems

Die Punkte 1-7 kosten Sie mit Sicherheit nur wenig Zeit, kann gut sein, dass es in 3-4 Minuten erledigt ist.

Also ran an die Einkreisung des Problems durch Ausschlussverfahren – wie die Profis! 😉

 

Für alle, die ein iPhone oder ein iPad besitzen, bietet sich als nützliches Tool die kostenlose App der Network-Scanner FING (s. Bild unten) an – damit werden die Netzwerk-Einstellungen wirklich zum Kinderspiel.

FING-Network-Scanner
WLAN mit Geräten und Adressen
Settings-FING
WLAN-Scanner mit Profi-Optionen
iPad-FING-IP-MAC-Adressen
iPad mit IP- und MAC-Adressen

1. Als erstes sollten Sie prüfen, ob die WLAN-Verbindung des Routers (der hat die Verbindung zum Internet Service Provider z.B. über DSL) mit einem anderen Gerät, z.B. Ihrem iPhone, iPad, Android-Smartphone oder einem WLAN-fähigen Windows-PC funktioniert. Klappt das problemlos, haben wir schon mal ein großes Problemfeld ausgeschlossen und können zielgerichtet weiter machen. Wenn also zumindest ein Gerät mit dem WLAN eine stabile Verbindung unterhält, dann können Sie mit 4. fortsetzen, sonst bitte erstmal vollkommen unabhängig den Router überprüfen und funktionsfähig für WLAN machen – das kann und will dieser Beitrag nicht leisten. Klappt es jetzt? Wenn nein, Fortsetzung danach mit 2.

2. Wechseln Sie einmal probehalber auf einen anderen WiFi-Kanal, falls Sie das 802.11g-Protokoll nutzen. Das muss beim Router eingestellt werden, die Einstellungen finden Sie typischerweise unter WLAN-Einstellungen. Wenn bisher der Funkkanal 1 genutzt wurde gehen Sie doch mal auf 5 oder 7, noch besser – falls möglich auf AUTO einstellen, dann wählt das System automatisch den besten Kanal.

3. Seltener sind auch die folgenden Einstellungen (bei älteren und nicht mehr standard-konformen Routern) zu ändern.

a) Der Router vergibt automatisch eine falsche IP-Adresse, unter der keine Einwahl möglich ist. Lösung: Setzen Sie eine feste IP-Adresse, z.B. 192.168.0.22, wobei die 22 nur einmal im Netz vergeben sein darf. In dem Fall setzen Sie die DNS-Adresse auf 192.168.0.1.  Die „0“ ist LAN-spezifisch, bei Ihnen kann es auch „2“ oder eine andere Zahl sein. Das müssen Sie im Router nachsehen, oder auf den funktionierenden Geräten (s. Punkt 1)

b) Sie haben DHCP nicht aktiviert? Dann manuell aktivieren.

4. Haben Sie das richtige Passwort für das WLAN verwendet? Klingt lächerlich, hat aber schon oft für viel Verdruß gesorgt. Überprüfen Sie bitte, ob Ihr Problem ganz simpel am falschen Passwort liegt. Sie werden lachen, wie oft dies der Fall ist. Wenn auch das Passwort stimmt, weiter mit 5.

5. Trennen Sie den AirPort mit „Airport deaktivieren“ und setzen Sie ihn wieder ein danach mit „Airport aktivieren“. Wenn Sie das schon mehrfach gemacht haben, brauchen Sie das nicht zu wiederholen, sondern setzen mit 6. fort.

6. Klicken Sie den AirPort an und klicken auf das Minus-Zeichen. Fahren Sie Ihr MacBook Pro herunter und starten es wieder neu. Nun klicken Sie unter “Systemeinstellungen->Netzwerk” auf das +Zeichen und fügen den Airport neu hinzu und aktivieren den Airport. Wenn Sie das schon gemacht haben, brauchen Sie auch das nicht zu wiederholen, sondern setzen mit 7. fort.

7. Reparieren Sie die Dateizugriffsberechtigungen unter Dienstprogramme, dann Festplatten-Dienstprogramm, Deine HD auswählen und klicken auf “Zugriffsrechte des Volumes reparieren”. Das Malheur mit der Zugriffsberechtigung kann z.B. durch ein Betriebssystem-Update enstanden sein.

Bei Fragen bitte unten Kommentieren.

 

Viel Erfolg!

 

Hattet Ihr auch Probleme mit Euren Apple-Produkten und keine offizielle Hilfe erhalten? Ihr seid nicht allein. Thema Kulanz bei Apple. Einzelschicksal?

Bitte teilen. Share the Love.

Danke! Merci! Thank you!

Kommentare: 66

  • #66

    Nyx Pankow (Sonntag, 04 Oktober 2015 18:50)

    Toller Artikel, vor allem weil ich mich hier in meinem Apple Frust verstanden fühle 😉

    Hab jetzt mal die Firmware in meiner Fritzbox geupdatet und mich vergewissert das WMM aktiv ist. Mal schauen wie lange es dauert bis ich das WLAN wieder ein- und ausschalten darf.

    Macbook Pro Late 2009. Die Probleme habe ich seit OSX 10.9… Mit 10.8 gab es keine Probleme soweit ich mich erinnere. Wenn das Problem wieder auftaucht downgrade ich auf 10.6.8 – Seit dem hat Apple eh nix mehr für mich brauchbares implementiert. Ich hab die Schnauze voll 😀

    Never upgrade a running System. Cheers!

  • #65

    hannah (Freitag, 05 Juni 2015 20:10)

    GENIAL !!!!! merci merci merci !

  • #64

    Axel (Sonntag, 30 November 2014 10:40)

    klasse Anleitung, danke! bei mir wars ganz einfach: Punkt 6 hat geholfen, habe allerdings vor dem Neustart die cashes gelöscht, obs nötig war weiß ich nicht.

  • #63

    Roland (Mittwoch, 26 November 2014 00:56)

    Also der Treiber-Downgrade hat bei mir funktioniert – vielen Dank!

  • #62

    Raupkolben (Dienstag, 11 November 2014 12:18)

    Nach allen guten Tipps, Ratschlägen und Versuchen, gab es leider keine Lösung.
    Also war ein letzter Versuch sich wieder in den Router einzuloggen und das Passwort zum 125mal zu überprüfen. Es war immer noch richtig. Passwort ganz leicht geändert im Router und siehe da es funzt wieder. Allerdings habe ich im Router noch zusätzlich den Kanal gewechselt. Sehr seltsam. Mein iPhone und iPad liefen die ganze Zeit reibungslos… Vielleicht hilft es ja jemandem. Dauert nur 30 sek! Kann man ja investieren, wenn man sowieso schon 6Std-lang versucht Internet mit seinem MacBook Pro zu haben… 😉

  • #61

    Joawah (Donnerstag, 16 Oktober 2014 23:43)

    Hi probiere mich in ein Hotel wlan einzuwähle iphone kein Problem aber Mac Book pro keine Chance habe es mit osx und Windows probiert.

  • #60

    Alexander Kirchhof (Mittwoch, 30 Juli 2014 17:57)

    Lieber Michael Zachrau,

    1000 Dank!

    Ich glaube auch bei mir funktioniert es wieder.
    Bis auf die Reparatur der Dateizugriffsberechtigungen hatte ich schon alles probiert (und noch einiges mehr …*), das scheint es dann aber gewesen zu sein, keine Paketverluste mehr, mal sehen ob das so bleibt (obwohl im Protokoll zwar eine Menge falsche Rechte auftauchten, ich aber nichts im Zusammenhang mit dem Netzwerk entdecken konnte).

    Ursprünglich war ich von einem DNS-Problem ausgegangen, da der Browser immer bei „Nachschlagen von …“ hängen blieb.

    Früher haben sich alle über kryptische Fehlermeldungen in Windows lustig gemacht und heute zerschießt MacOS die Dateizugriffsrechte und danach geht das WLAN in bestimmten Settings kommentarlos regelmäßig einfach nicht mehr …

    Was kann man dazu noch sagen?

    Außer besten Dank und schöne Grüße

    ___________________________________

    *
    – festen DNS eintragen (z.B. 8.8.8.8) (half gar nicht)
    – den Prozess „mDNSResponder“ beenden und neustarten (half manchmal für kurze Zeit)
    – DNS-Cache löschen mit (half manchmal für kurze Zeit)
    sudo dscacheutil -flushcache
    und
    sudo killall -HUP mDNSResponder
    – die hier
    http://www.makingitscale.com/2011/broken-search-domain-resolution-in-osx-lion.html
    und hier
    http://www.eigenspace.org/2011/07/fixing-osx-lion-dns-search-domains/
    beschriebenen Änderungen in
    /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist
    (Halfen gar nicht, com.apple.mDNSResponder.plist ist wieder im Originalzustand.)
    – OS X 10.9.4 reinstallieren (allerdings kein „Clean Install“, den Rechner komplett platt zu machen erschien mir unangemessen aufwändig) (half evtl. für kurze Zeit, unklar)
    – die Netzwerkumgebung wechseln bzw. WLAN aus und wieder an (half manchmal für kurze Zeit)
    – Faktory-Reset der Fritzbox und Neueinrichten des Netzwerks
    – …
    und natürlich die Punkte 1 bis 6 von oben

    MacBook Pro, 13 Zoll, Ende 2011
    Software OS X 10.9.4 (13E28)
    Fritzbox 7490

  • #59

    Daniel (Dienstag, 17 Juni 2014 20:47)

    …und sorry für meine harschen Worten von zuvor, die gehen an Apple und nicht an die Community hier!

  • #58

    Daniel (Dienstag, 17 Juni 2014 20:45)

    Habe eben noch einmal der Reihen nach alle inzwischen gesammelten Tips durchprobiert, wieder ohne Erfolg. Aber: Ich habe einen wesentlich besseren Workaround gefunden als ständiges ein/ausschalten des WLAN.

    Bei mir (OSX 10.9.3, Macbook Retina 13″ Late 2013) hilft es (reproduzierbar auch nach mehreren Neustarts bis jetzt in zwei verschiedenen Netzwerken getestet) durchgehend einen Ping auf einen Server laufen zu lassen (also Terminal öffnen und z.B. ping www.google.de eingeben).

    Das Problem kommt womöglich von einer sehr konservativen Energiespareinstellung des WLAN Treibers, wenn ich mein Macbook also per Dauerping zwinge, ständig eine Verbindung zu irgendeinem Server aufrecht zu halten, dann darf ich surfen, uploaden etc.

    Riesenschlamperei was Apple da liefert, jetzt bleibt die Hoffnung dass dieses Problem unter oben genannter Konfiguration zumindest nicht von der Hardware her kommt und hoffentlich bald in einem Software/Treiberupdate gelöst wird.

    Hoffe damit dem ein oder anderen genervten MBPR Besitzern helfen zu können… Falls bei euch euer WLAN gerade ausnahmsweise funktioniert schaut doch mal auf www.nomadic-spirit.com vorbei, dann wisst ihr auch warum ich ständig in verschiedenen Funknetzwerken am werkeln bin! LG

  • #57

    Daniel (Dienstag, 17 Juni 2014 19:51)

    Was sind das denn hier für schlechte Witze? Wenn ich nur zu Hause sitze und ein bissl am WLAN daddeln will ist das ja ganz toll, aber wer das Gerät UNTERWEGS verwenden möchte (und dafür ist so ein verfluchtes Notebook eben gebaut) kann doch nicht mal schnell den Sendekanal des Hotels, den IP Range oder die Verschüsselungsart umstellen!!! Und das dann jeden Tag im Hotel/Hostel/Bahnhof/Flughafen/Starbucks!?!?? Ich lach mich schlapp, 1500€ in den Sand geschossen. Bin ein echt besonnener Charakter aber hier bleibt nur zu sagen FUCK APPLE, NIE WIEDER! (Bevor jemand fragt, ja ich habe alles probiert, auch eure sieben Tips… Das einzige was „hilft“: Alle fünf Minuten den Adapter aus/einschalten) Macbook Retina 13″ Late 2013, so ein DRECKSPRODUKT!

  • #56

    Hardi (Mittwoch, 11 Juni 2014 21:20)

    @Thomas
    Hallo, ich hätte meine Probleme mit dem WLAN am neuen Macbook Pro Retina 13“ auch gerne so einfach gelöst.
    Leider sieht meine Fritzbox Fon 7270 die Verschlüsselung WPA2-Personal nicht vor.
    Alle anderen Geräte, wie iphone 4s oder Notebook Siemens fujitsu funktionieren am WLAN an gleichen Standorten einwandfrei.

    Hast Du ggf. einen moderneren Router? Wobei meine FritzFon Box 7270
    ja eigentlich auch ein guter Router ist. Die aktuelle Firmware habe ich erst heute frisch installiert.

  • #55

    Thomas (Donnerstag, 22 Mai 2014 16:11)

    @Michael,
    Ich habe ein Macbook Pro Retina und massive wifi Probleme gehabt. Die Problematik habe ich vorher schon einmal beschrieben.
    Heute habe ich vom apple Support einen Link mit empfohlenen Netzwerkeinstellungen erhalten:
    http://support.apple.com/kb/HT4199?viewlocale=de_DE

    Nach der Umstellung der WLAN Verschlüsselung von WPA/WPA2 auf WPA2-Personal (AES) waren die wifi Probleme verschwunden.
    Mein Netzwerk läuft derzeit stabil. Ich muss das Ganze noch etwas länger beobachten, da es immer mal wieder Phasen ohne Probleme gab.
    Aber wie gesagt, seid der Umstellung läuft mein Netzwerk so wie es sein soll.
    Die Probleme traten übrigens nicht bei meinen iphone, apple tv oder irgendwelchen anderen Netzwerkgeräten auf.

  • #54

    CJ (Sonntag, 18 Mai 2014 20:16)

    Bei mir ist es besonders dubios. Ich bin begünstigt mit mehreren Generationen von Macbook (Pros) alle 12/13 Zoll. Genration early 2011, late 2012, Alu Macbook 2008 und ein 2005er Powerbook.
    Das Powerbook hatte das Problem nie. Sowie das 2008er Macbook. Alle Macbooks stehen also quasi nebeneinander und die „Opas“ machen keine Mucken während die modernen Geschwister ihre unlogischen Problemchen (Zeitüberschreitung) haben. Das macht natürlich besonders agressiv. Denn man ist sich sicher es geht doch (unter Leo und Snowleo)
    2 Mac funktionieren 2 nicht. Und das wie sie gerade bequem sind. Denn mal funktionieren auch diese doch nachdem einmal das Problem aufgetreten ist, ist an kein WLAN zu kommen… Einfach ätzend.
    Zu Hause gibt es ja noch die Möglichkeit auf ein Kabel umzusteigen aber macht das mal in einem Starbucks…

    Leider alles Broadcom :,(

  • #53

    Steffen (Donnerstag, 08 Mai 2014 15:25)

    Gibt es eine Möglichkeit den alten Treiber wiederherzustellen? Kann man den manuell einfach wieder drüber installieren?

    Mit dem Tipp von heise.de konnte ich leider nichts anfangen. Hab wohl etwas überstürzt einfach den alten Treiber installiert und bekomme nun die Meldung: „WLAN: Keine Hardware installiert“. Habe 10.9.2. drauf. Danke für die Hilfe.

  • #52

    Thomas (Donnerstag, 08 Mai 2014 11:11)

    @Michael,
    sie haben ein Ping Dauertest durchgeführt und festgestellt, dass zu viele Pakete verloren gehen. Daraufhin wurde meine AirPort Karte ausgetauscht. Eine Woche ging das ganze gut und seid heute habe ich wieder Probleme.
    Jetzt werde ich mir wohl die AirPort Karte deaktivieren, mir einen wifi USB Stick kaufen und zukünftig auf Apple Produkte verzichten.

  • #51

    Michael Zachrau (Mittwoch, 07 Mai 2014 16:07)

    @Thomas na, was ist rausgekommen im Apple-Store?

  • #50

    Mouara (Dienstag, 06 Mai 2014 15:21)

    ……ich habe jetzt einfach mal das Wlan-Netzwerk umbenannt. Jetzt geht wieder alles. Mal sehen, wie lange…

  • #49

    Mouara (Dienstag, 06 Mai 2014 13:13)

    Hallo…wir haben das Problem auch sein ca. 2 Wochen mit einem MacBook Pro 13″ mit OS X 10.9.2 und Broadcam-Karte. Davor hat es ein Jahr lang tadellos funktioniert….ich habe Punkte 1-7 ausprobiert, leider ohne dauerhaften Erfolg. Lustigerweise hatte zur gleichen Zeit auch unser iMac ein WLAN-Problem, was sich aber mit einem Update der Routersoftware beheben lies.
    War da irgendein OS-Update der Auslöser? Hat noch jemand eine Idee? Sonst wird uns der Gang zum Applesstore nicht erspart bleiben. Und der scheint ja häufig nicht so glücklich verlaufen zu sein…

    Vielen Dank für Antworten!

  • #48

    Thomas (Freitag, 02 Mai 2014 10:43)

    Hallo,
    Ich habe gerade mein MacBook Pro Retina zur Analyse im Apple Store abgegenen. Natürlich funktionierte mein Mac im Apple Store wifi einwandfrei. Nur leider bei mir und in vielen anderen wifi nicht. Der Mitarbeiter tat so als trete das Problem nur bei mir auf. Mein Verweis auf für Foren im Internet begegnete er mit der Aussage „Für uns ist nicht relevant was irgend welche Leute im Internet schreiben“.
    Bin gespannt was rauskommt.

  • #47

    Marianne (Mittwoch, 16 April 2014 22:44)

    Vielen Dank lieber Michael. Ich schaue mir das gerne mal an.
    Ich melde mich wieder.

  • #46

    Michael Zachrau (Mittwoch, 16 April 2014 20:47)

    @Marianne, sei froh, Du kannst aufatmen und brauchst Dir nicht mehr die Haare zu raufen. Wenn Du in andere Netzwerke kommst, hat Dein neues MacBook Pro Retina NICHT das hier behandelte Problem. Bei Dir zu Hause liegt das Problem in Deinem Netzwerk (z.B. Router). Das Zeitlimit deutet auf eine Fehleinstellung. Eine Antwort für Dein Problem findest Du z.B. unter http://www.gutefrage.net/frage/macbook-zeitlimit-ueberschritten .

  • #45

    Marianne (Mittwoch, 16 April 2014 19:35)

    Hallo, ich habe mir alles von oben bis unten durchgelesen und raufe mir die Haare , weshalb ich nicht auf diese Seite bin, bevor mir eben diese besagte Macbook Pro Retina vor zwei Tagen gekauft habe…..!! Alles dito wie oben beschrieben, nix genützt, ich komme nicht in mein Netzwerk rein, verflixt! „Zeitlimite überschritten“ Was heisst das?
    Allerdings funktioniert das WLAN auf anderen Netzwerken bis jetzt ohne Probleme.
    Warum also bei mir zu Hause nicht?
    Habt Ihr Tipps?

    Allerdings komme ich in

  • #44

    Michael Zachrau (Mittwoch, 19 März 2014 14:43)

    @all Bitte schön, gern geschehen!
    Freut mich sehr, dass es so gut klappt. Ist bestimmt auch fair, wenn Ihr Euch mit einem kleinen Facebook Like (ganz oben) oder mit einem „Gefällt mir“ (vor den Kommentaren) für die Hilfe bedankt, oder ;-)?

  • #43

    Tom (Mittwoch, 19 März 2014 14:20)

    Hi, vielen vielen lieben Dank für diesen tollen Tip. Es hat mir Nerven Zeit und Geld gespart. Nach Punkt 6 hat alles wieder funktioniert 😉 DANKE !!

  • #42

    Andre Hillebrand (Dienstag, 18 März 2014 17:58)

    Hallo,

    ich habe noch eine Lösung: die Datei “ com.apple.Bluetooth.plist löschen.
    Wenn man neu startet erstellt sich die Datei neu.
    Die WLAN Probleme waren bei mir danach weg.

    LG Andre

  • #41

    Michael Zachrau (Mittwoch, 12 März 2014 01:58)

    Ein Quickfix von Patrick Sprecher, auf Twitter vorgeschlagen:
    Bluetooth aus, stattdessen Microsoft wireless USB Maus nutzen und dann angeblich WLAN forever!
    Habe es bisher nicht probiert. Feedback?

  • #40

    Michael Zachrau (Donnerstag, 06 März 2014 17:38)

    @andy
    http://www.heise.de/ct/hotline/Mac-OS-Treiber-loswerden-1183265.html

    „Eine Liste der geladenen Kernel-Extensions (Treiber in Mac OS X), die nicht von Apple stammen, erhalten Sie mit dem Befehl kextstat | grep -v „apple“. Beim Systemstart lädt Mac OS X üblicherweise die Extensions aus dem Verzeichnis /System/Library/Extensions/.
    Über den Namen sollten Sie das zugehörige Verzeichnis finden. Sie können dann eine Extension aus dem Weg räumen, indem Sie diese aus diesem Verzeichnis heraus etwa in Ihr Home-Verzeichnis verschieben…“

  • #39

    andy (Donnerstag, 06 März 2014 13:28)

    Funktioniert nicht. Wie werde ich das, was ich jetzt installiert habe, wieder los?

  • #38

    Michael Zachrau (Freitag, 28 Februar 2014 10:15)

    @Tom

    Systeminformationen / Netzwerk/ WLAN / Schnittstellen / en0 / Firmware-Version:

    Da steht dann z.B. Broadcomm BCM43xx 1.0 bei mir

    Viel Erfolg und bitte melden, wenn es funktioniert oder weitere Fragen bestehen.
    Gruß Michael Zachrau

  • #37

    Tom (Donnerstag, 27 Februar 2014 15:28)

    Hallo Herr Zachrau

    ich habe ein MBPro 2012 mit OSX 10.9.2.
    Wo sehe ich denn ob ich eine Atheros oder Broadcom WLAN Karte habe.? Mein Systembericht weist dazu nichts aus !

    Gruß Tom

  • #36

    yamaha (Dienstag, 21 Januar 2014 13:23)

    @Raphael und @Lukas,

    habt ihr beiden schon ne Lösung? An meinem MBP ist genau derselbe Fehler. Ich weiß leider auch nicht, wie ich die „alten“ Treiber neu installieren kann.

    Gruß yamaha

  • #35

    Christopher (Montag, 30 Dezember 2013 18:54)

    Einfach nur Schlecht der Text am Anfang, mehr Sachlichkeit würde ich mir wünschen.

  • #34

    Acubens (Dienstag, 10 Dezember 2013 20:10)

    Lieber Michael Zachrau,
    danke für den tollen Beitrag und für die Tipps. Auch an die Leser, die Kommentare mit Hinweisen ergänzt haben vielen Dank an der Stelle.
    Ja, ich habe auch das WLAN-Problem, und das von der ersten Stunde als ich mir den damals neu auf dem Markt gekommenen MACBook Pro Retina angeschafft habe. Und ich muss sagen, ich habe eine ewige Zeit benötigt bis ich dann mal auf die Idee gekommen bin, dass es nicht an meinen Einstellungen liegen kann, sondern offensichtlich ein Problem der Hardware/Software? ist. Ich tippe eher auf Hardware. Ja, ich habe mir auch etliche Tipps anhören müssen, im Internet auf einer Vielzahl von Seiten Möglichkeiten und auch viel Mist lesen müssen, woran das wohl liegen könnte. Fakt ist, dass es offensichtlich ein Problem bei den Geräten mit Störung von WLAN über Bluetooth gibt. Allerdings muss ich feststellen, dass das Ausschalten des Bluetooth (könnte auch ohne Maus leben) leider das Problem nicht wirklich löst.
    An meinem Gerät ist folgende Reaktion vorhanden (unter Mountain Lion und auch noch unter Mavericks, wenn vielleicht auch etwas extremer – das ist aber nur Gefühlsmäßig, nicht gemessen): Gerät einschalten, WLAN sucht und sucht … nix gefunden. WLAN aus – an, warten, mal gehts dann, mal nicht. Gerät zuklappen (ohne ausschalten), aufklappen: WLAN findet 100% sicher die Verbindung nicht mehr. WLAN aus/an, WLAN meldet, keine Internetverbindung, aber Knoten gefunden (Ausrufezeichen im Symbol WLAN). Also aus/an, aus/an, oh! Freude!!! Der >> 2500 Euro teure Rechner kommt ins WLAN!!! (Anmerkungen, es soll auch günstigere geben, die das einfach so können…).
    Also: Lesen, was hier falsch ist. WLAN komplett entfernen, wieder aktivieren… hilft nichts. Routereinstellungen prüfen… Router aus/an schalten… Ok, zuhause kann ich das mal machen aber ich arbeite an einer Hochschule mit komplett vernetztem WLAN-Campus. Wen soll ich da bitten den Router mal kurz abzuschalten???
    Also, Rechner zur IT im Fachbereich. Kompetente Leute, auch für MAC. Rückmeldung: Kauf dir einen Windows-Notebook. Da gibts so Probleme nicht! OK. Genau das wollte ich hören…. Nein, Windows kommt mir nur ins Haus, wenn nix mehr geht!
    Man muss sich das also mal vorstellen, ich habe einen weißen MACBook der fast 10 Jahre alt ist und der rennt ins Internet ohne Mucken und schnell. Gab noch nie eine Situation, wo ich auf eine WLAn-Verbindung warten musste. Und jetzt? MACBook Pro wird in der Lehre online mit Beamer verwendet… Eine Vorführung online und – peinlich – muss mir von 100 Studierenden anhören, dass ich mir mal einen gescheiten Rechner kaufen soll.
    Aber: Ich habe eine Lösung gefunden. Der alte MacBook (White) funktioniert immer und den nehme ich jetzt wieder 🙂 Und die Laune lass ich mir nicht verderben!
    Jetzt habe ich mich bei Apple erkundigt, ob das Problem mit dem WLAN beim neuen MACBook Pro behoben ist. Ich würde sogar in den sauren Apfel beißen und mir einen neuen (nach weniger als 1 Jahr) holen. Hauptsache der Ärger ist weg. Antwort? Welche Probleme??? Haben Sie schon mal den Router aus/an geschaltet?
    Liebe Äppel, das ist unterirdisch was ihr euren Usern zumutet! Beim Auto gäbe es eine Rückrufaktion!!! Ohne wenn und aber! Aber ich muss gestehen, jeder dem ich um Hilfe fragte war super freundlich, zuvorkommend, hatte Mitgefühl und wollte mir auch wirklich helfen (wenn er könnte). Nix also gegen den Service!

    So, und nun einen weiteren Tipp zum probieren. Das hilft sehr häufig:
    Wenn’s mit dem WLAN nicht klappt, dann auf dem Icon oben rechts drücken und Systemeinstellungen Netzwerk öffnen. Dann den Assistenten… öffnen und auf Diagnose drücken. Fortfahren bestätigen, dann den Zugriff auf den Schlüsselbund erlauben (immer erlauben braucht man nicht zu wählen, das merkt er sich sowieso nicht), Fortfahren … beenden und in 60 – 70% der Fälle ist dann WLAN und Internet da. Hab schon darüber nachgedacht, ob man dafür eine App entwickelt, die die Klicks etwas beschleunigen.

    Liebe Mitbetroffene, nicht verzagen und nur nicht aufregen, das ist die Sache nicht Wert und geht auf die Gesundheit!
    Und, von Apple werden wir dazu ganz bestimmt nichts hören und auch keine Abhilfe bekommen. Die Chance hätten sie mit Mavericks sicher schon genutzt!

    Liebe Grüße an alle, die genau die gleichen Erfahrungen gemacht haben!

  • #33

    Michelle (Samstag, 30 November 2013 16:00)

    Habe ein sehr neues MacBook Pro Retina diesen Juni 2013 im Apple Store in München gekauft. Bin total am Ende nach über 2 Stunden Anweisungen befolgen um das Problem zu lösen, was einfach nicht gelingt. Ich könnte ko…..n. sorry, aber was nützt mir das Gerät denn jetzt noch? Den Download würde ich ja gerne machen, aber wie ohne Internetverbindung??????????????????

    Hoffe Hilfe kommt schnell. Danke sehr. LG

  • #32

    Lukas (Mittwoch, 16 Oktober 2013 18:28)

    @Michael @Raphael

    Ich habe das selbe Problem, allerdings mit meinem Macbook Pro. Wie kann ich die Wlan-Karte / Treiber wieder (richtig) installieren?

    Ich bin genauso wie Raphael vorgegangen und habe das selbe Problem.

    Vielen Dank schon mal, falls mir jemand helfen kann!

  • #31

    Michael Zachrau (Montag, 14 Oktober 2013 20:33)

    @Raphael,
    was für einen Mac Mini gut ist, kann ich Ihnen leider nicht sagen. Unsere Lösung ist für einen MacBook Pro (s. Titel, 😉
    Wenden Sie sich am besten direkt an einen Apple-Händler Ihres Vertrauens. Sorry, die Unterschiede der Systeme sind größer als man denkt. Viel Glück!

  • #30

    Raphael (Sonntag, 13 Oktober 2013 00:58)

    Hallo Herr Zachrau,

    Ich habe die von Ihnen beschriebenen Schritte 1-7 befolgt, jedoch ohne positives Ergebnis.
    Danach habe ich die Datei „osx_atheros_3.2_kext.zip“ gedownloadet, entzippt und die Datei IO80211Familiy.kext gegen die bestehende Datei im Ordner System/Library/Extensions ausgetauscht (macmini, OS X 10.8.3). Dabei habe ich die ursprüngliche Datei vorsichtshalber auf dem Desktop kopiert.
    Nach dem Kopiervorgang habe ich den Rechner neugestartet. Leider zeigt mir das WLAN-Icon die Meldung: „Keine Hardware installiert“. Ich hatte natürlich versucht, die ursprüngliche Datei vom Desktop zurück in den Extensions-Ordner zu kopieren. Aber auch danach blieb die Meldung bestehen und die WLAN Funktion lässt sich seitdem nicht mehr über die Systemeinstellungen ansprechen. Was ist also passiert und was bedeutet das?

    Vielen Dank für Ihre Rückmeldung.

  • #29

    Michael Zachrau (Freitag, 04 Oktober 2013 15:43)

    @Rainer
    Ich würde mir erst mal Punkt 1 (s.o.) anschauen, ob a) ein anderes Gerät mit dem WLAN klarkommt und b) Ihr Mac woanders (anders WLAN) zurechtkommt. Dieser Ausschluss-Schritt spart oft sehr viel Zeit. Und dann alle weiteren Punkte durchgehen. Erst wenn alle Punkte von 1-7 nicht funktioniert haben, würde ich mich mit dem Apple Support in Verbindung setzen.

  • #28

    Rainer (Dienstag, 01 Oktober 2013 19:21)

    Hallo, auch von mir ein grosser Dank. Das hat bei mir zunächst für Wochen geklappt und nun ist schon wieder das gleiche Problem aufgetreten. Airport verabschiedet sich von alleine und ich spiele den alten Treiber auf, nur diesmal verabschiedet sich das WLAN schon wieder nach Minuten. Ich bin komplett verzweifelt, weil mir keiner der hochbezahlten Sys Ads helfen kann. Hilfe, was kann ich noch tun?

  • #27

    Johanna (Sonntag, 29 September 2013 02:14)

    Auch von mir ein großes DANKE! Auch ich hatte Schwierigkeiten mit dem neuen Macbook pro online zu gehen. Dank Ihrer Hilfe ist es dann doch gelungen. Schön, dass es Online-Engel gibt!
    DANKE!

  • #26

    Ulrike (Dienstag, 17 September 2013 22:06)

    Vielen Dank für diesen hilfreichen Artikel! Bei mir hat Punkt 7 geholfen. Super klasse!

  • #25

    Christian (Dienstag, 17 September 2013 22:05)

    Hi,
    erstmal danke für die Infos. Man findet echt manchmal nur Schwachsinn.
    Leider kann ich die Datei nicht öffnen um sie zu installieren. Beim googeln des Programmes bin ich auch nicht weiter gekommen… Bräuchte da noch etwas hilfe.
    Danke

  • #24

    Henry (Donnerstag, 15 August 2013 21:10)

    Vielen Dank für den guten Tipp, die Zugriffsrechte zu reparieren. Jetzt geht die Verbindung zu allen Internetseiten mit meinem Powerbook wieder perfekt und schnell.

  • #23

    QuickMik (Montag, 05 August 2013 10:19)

    der eintrag ist von 04.2012…..
    und noch immer keine lösung. das ist echt schwach.
    ich hab hier einige mobile geräte. das ganze betrifft nicht nur das retina sondern auch das MBP.
    ganz egal ob es ein 2010 oder ein 2011er modell ist.
    shame on you apple. shame on you

  • #22

    cm (Mittwoch, 19 Juni 2013 20:31)

    Echt super geklappt! Vielen Dank! Endlich mal ein kompetenter Lösungsvorschlag!

  • #21

    Michael Zachrau (Sonntag, 09 Juni 2013 12:59)

    @Sandra
    Suche Dir am besten jemand aus Deinem Kollegen/Bekannten/Freundes-Kreisen aus, der Dir mal ein paar grundlegende Dinge zeigt und einrichtet. Das kann über Blog oder Forum nur schiefgehen und trotzdem sehr lange dauern. Deine eigenen Bemühungen , Du hast es immerhin selbst versucht, sind aller Ehren wert. Aber „Help yourself“ ist für diejenigen keine gute Lösung, die noch wenig Handlungssicherheit bei der System-Komplexität haben.
    @oxel
    Kompliment für die Geduld. Ich habe tatsächlich einen Tipp für Dich. Eine iPhone-App, die Dir helfen kann, das Problem zu eliminieren: FING. Ziemlich toll, was das kleine Ding über Deine LAN-Topographie und die Netzwerkverbindungen, IP-, Mac-Adressen etc. alles so verrät. Das Ding stammt übrigens weder von mir noch von Partnern – ist aber trotzdem toll 😉 Ich glaube, es ist sogar kostenlos oder jedenfalls sehr preiswert.
    Ich habe oben mal einen Bildschirmausschnitt von FING in den Artikel gestellt.
    Ich würde damit mal nach dem Ausschlußverfahren erst mal schauen, welches Teil in der Kette nicht funktioniert. Immerhin weißt Du ja jetzt, dass es grundsätzlich geht.
    Viel Erfolg allen hier.

  • #20

    Wittich (Sonntag, 09 Juni 2013 12:36)

    Super, danke. Das hat bestens geklappt und war die Rettung. Ich hatte schon befürchtet, dass es viel zeit in Anspruch nimmt, dieses Problem zu lösen. Vor dem Update auf 10.8.4 hatte mein WLAN auf dem MacBook gut funktioniert, danach gab es die Fehlermeldung wegen Zeitüberschreitung. Nach dem Runterladen und Installieren, so wie es hier beschrieben steht, hat sich mein MacBook nach dem Neustarten anstandslos wieder ins WLAN eingewählt. DANKE!!!!

  • #19

    oxel (Freitag, 07 Juni 2013 21:57)

    Hallo Herr Zachrau,
    ich habe das mit dem anderen Netz mal ausprobiert. Es ist wohl in der Tat so, dass die andere Verbindung stabil ist. Meine Verbindung ist gegen eine Time-Capsule die konfiguriert die hinter einem Kabel-Modem hängt und das WLAN macht. Hätten Sie eine Idee dazu?
    Gruß
    oxel

  • #18

    Sandra (Mittwoch, 05 Juni 2013 16:47)

    Hallo,

    ich hab das alles gemacht wie beschrieben mit dem Ergebnis das jetzt GAR nichts mehr geht. Er sagt mir immer „Zeitüberschreitung“ bei der Wlan Verbindung und behauptet dazu noch das Passwort wäre falsch (was es definitiv nicht ist).
    Bitte dringend um Hilfe (hab natürlich kein Time Machine back up gemacht…)

  • #17

    Oxel (Montag, 03 Juni 2013 20:27)

    Hallo Herr Zachrau,
    ja die Schritte oben habe ich durchgeführt. ich habe sogar den Treiber mit einem Update versehen. Das mit der Umgebung werde ich mal testen. Melde mich wieder.
    Danke+Gruß
    oxel

  • #16

    Michael Zachrau (Samstag, 01 Juni 2013 15:41)

    @Oxel
    Hast Du die Schritte 1-7 (s.o.) durchgeführt?
    Hast Du mal ausprobiert, ob Dein MacBook in einer anderen WLAN-Umgebung (anderer Router) gute Verbindungen hinbekommt?

  • #15

    Oxel (Freitag, 31 Mai 2013 23:54)

    Hallo,
    ich habe eine Broadcom Karte. Gibt es hierfür auch eine Lösung? Habe den Downgrade trotzdem durchgeführt. Hat aber nichts gebracht.
    Hat jemand eine Idee?
    Gruß
    Alex

  • #14

    Michael Zachrau (Freitag, 24 Mai 2013 11:50)

    @ben
    Du findest ein ZIP-File. Dies ist eine komprimierte Datei. Normalerweise kannst Du durch Klick darauf das File entpacken. Dann siehst Du den Inhalt eine Datei namens kext… Wenn Du jetzt nicht weiter weisst, brauchst den Kext Helper oder das Kext Utility. Einfach googlen – kein Problem. Es würde länger dauern, das hier zu beschreiben, als Deine Suche bei Google.
    Viel Erfolg, es hat bisher immer funktioniert!

  • #13

    ben (Donnerstag, 23 Mai 2013 22:16)

    hallo zusammen,

    auf welche datei muss ich klicken, um es installieren zu können?

    wenn es installiert ist: wie weiter?

    habe es mal probiert zu installieren, aber w-lan ist immer noch gleich

    wäre sehr froh um eine rasche Antwort

    danke vielmals

    ben

  • #12

    Michael Zachrau (Sonntag, 12 Mai 2013 12:54)

    @Marc
    Frag einen, der Dir gegenüber zumindest 2h Erfahrungsvorsprung mit dem Mac hat – er/sie wird es Dir sagen;-)
    Wenn Du noch nie irgendwas installiert hast – lass es Dir zeigen – es ist super-einfach!

  • #11

    Paul (Samstag, 11 Mai 2013 21:11)

    Sieht bisher gut aus. Wenn das die Lösung des Problems ist, dann hat mir das mal eben einen neuen Rechner gespart. Ich war schon drauf und dran das ältere Mac Book auszutauschen, weil die WLAN Problem so massiv waren, dass es nicht mehr sinnvoll eingesetzt werden konnte.

  • #10

    Marc (Donnerstag, 09 Mai 2013 11:25)

    Welche Datei muss ich installieren?

  • #9

    Max Heetel (Dienstag, 07 Mai 2013 19:00)

    @ Judith
    exakt den gleichen Mist haben die mir auch erzählt!

  • #8

    Max Heetel (Dienstag, 07 Mai 2013 18:52)

    Habe auch den Broadcom Chip und bislang keine Lösung gefunden.
    War auch schon ca. 2h telefonisch mit Technikern von Apple Care zugange, hat auch nichts gebracht.
    Das neue MBP ist echt fürn Arsch!

  • #7

    Andi (Dienstag, 30 April 2013 19:28)

    hmm, hab leider einen Broadcom Chip, kennt wer dafür eine lösung (MBP 15″ Retina inkl. WLAN Problem und Hänger)

  • #6

    Vladimir Martinko (Mittwoch, 24 April 2013 09:40)

    Es erfüllt mich mit Angst, dass die gewohnt Apple Stabilität langsam den Bach runter geht …. Die beschriebenen Abbrüche und Performanceschwankungen habe ich auch bei meinem IPad dort habe ich leider keine Möglichkeit einen Treiber zu downgraden. Wie gehabt gibt es auch hier einiges in den Foren zu lesen …. Zu viel. Haben Sie da einen Tipp für mich?

    Vielen Dank!

  • #5

    Michael Zachrau (Montag, 22 April 2013 15:16)

    @Christina
    Ich erkläre es gern, bisher hat es noch bei allen geklappt. Einfach installieren, wie alle Programme auch – durch Anklicken. Bei Fragen, einfach anrufen oder Mail (s.o.) Viel Erfolg!

  • #4

    Christina (Dienstag, 09 April 2013 03:07)

    Hallo, vielen Dank für diesen Artikel. Ich habe den Treiber heruntergeladen, bin aber unsicher, was genau ich installieren muss…
    Zudem bekomme ich egal was ich anklicke, immer eine Fehlermeldung.

  • #3

    Daniel (Freitag, 05 April 2013 07:40)

    Mann sollte sich zusammentun: je ein Software und ein Hochfrequenz-Spezialist und vier Anwälte (die vom schlimmsten Schlag) und dann vor dem WiFi-Konsortium Apple das WiFi-Logo entziehen. Anschließend den kleinsten Fehler finden und die CE-tauglichkeit entziehen lassen. Dann wird Apple ganz schnell reagieren, denn sonst müssen die Geräte in der EU per Rückruf ausgebessert werden. Ach, ein schöner Traum.

  • #2

    Judith (Montag, 11 März 2013 20:57)

    Vielen Dank!! Ich bin fast verzweifelt an dem Problem und bei Apple hat mir niemand weitergeholfen. Alle haben so getan, als hörten sie das Problem zum ersten Mal und haben Firmwareupdates meiner FritzBox vorgeschlagen. Jetzt funktioniert es endlich.

  • #1

    Ariane (Montag, 11 März 2013 08:34)

    Steve Jobs soll zurück kommen!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.